SearchBackendError on MayanEDMS v4.4

So I am using MayanEDMS on version 4.4 and I have been quite happy with it, but I noticed that when I search inside of a cabinet, I receive the following error:

The exception itself does not really make sense to me since there are only ~30 documents in the regarding cabinet.

Something noteworthy is, that I am still using the DjangoSearchBackend, although the default is the WhooshSearchBackend (afaik). As for the normal or extended search, I dont seem to get this error.

Does anyone maybe have an idea what could cause this? Maybe some issue with tesseract or something? (I remember there being some tesseract error in my docker logs but it did not seem to affect the system itself so I disregarded it for now)

I really appreciate any help, thank you in advance.

Please check the output of:

docker compose logs -f

as you trigger the error in the UI to obtain a detailed output of the cause.

I see the issue.

Search results exceed limit setting

The Django search backend does not support searching all values with a single query. This is emulated using a complex search applied to every possible field that can be searched. If the object being searched has 30 search fields, then 30 queries will be made and their results aggregated.

You can try increasing the value of the setting MAYAN_SEARCH_RESULTS_LIMIT from 1000 but the probabilities of improvement are not high since this is a Django database ORM limitation.

In this case, would it be possible to reduce the search_fields that are searchable?

In this case the searched objects are documents and our users seem to only (want to) search by label in general.

I “removed” some of the search_fields in “mayan/apps/documents/” to remove the option to search these fields in the advanced search (since some are quite sophisticated). Could this have an effect on the error at hand?

Regarding the MAYAN_SEARCH_RESULTS_LIMIT, the SEARCH_RESULTS_LIMIT in the Mayan GUI Settings (under Search) was already set to a 1000 by me beforehand, so as you suggested, this did not really improve anything.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.