Upgrade from 4.0.22 to 4.2.5 - Sources not working anymore (solved)

When things don't work as they should.
Post Reply
Posts: 17
Joined: Mon Oct 05, 2020 4:10 am

Upgrade from 4.0.22 to 4.2.5 - Sources not working anymore (solved)

Post by bernroth »

Dear Community!

We recently upgraded our Mayan EDMS installation (based on docker-compose) from 4.0.22 to 4.2.5.
After upgrade we found that the sources were not working at all.

"Test" and "Error log" were empty but looking at the container logs, we found some "ModuleNotFound" errors.

Code: Select all

app_1                                     | mayan.apps.databases.model_mixins <286> [ERROR] "get_backend() line 37 ModuleNotFoundError while importing backend: mayan.apps.staging_folders.source_backends.SourceBackendStagingFolder; No module named 'mayan.apps.staging_folders'"
Quickly I realized that the migration process was not able to correctly convert the source type "Watch folder" and set it to "Null".

Instead of searching the root cause (possibly something suring the conversion process), I deleted all sources and recreated them.

All problems or error messages related to sources were gone, all pending documents processed.

Best regards,
Post Reply