Problem with docker-compose installation on Linux Mint

Questions, comments, discussions. Over time certain topics might be moved to their own category.
Post Reply
rozen
Posts: 2
Joined: Mon Jun 06, 2022 2:45 am
Location: Point arena, CA

Problem with docker-compose installation on Linux Mint

Post by rozen »

I would like to have a simple to use EDMS system to keep track of a relatively small number of personal documents. I am hoping that Mayan will do that for me so that I don't have to clobber up one myself. I don't understand a couple of setting in ".env": MAYAN_TRAEFIK_LETS_ENCRYPT_EMAIL which in ignorance I set to my email address and MAYAN_TRAEFIK_EXTERNAL_DOMAIN for which I have no understanding. I have attached my .env and
docker-compose.yml files.

I get errors when trying to use docker-compose on Linux Mint 20.3. The output I get is:

rozen@atlas: ~ > sudo docker-compose --file docker-compose.yml --project-name mayan up --detach
WARNING: The MAYAN_WORKER_CUSTOM_QUEUE_LIST variable is not set. Defaulting to a blank string.
ERROR: Version in "./docker-compose.yml" is unsupported. You might be seeing this error because you're using the wrong Compose file version. Either specify a supported version (e.g "2.2" or "3.3") and place your service definitions under the `services` key, or omit the `version` key and place your service definitions at the root of the file to use version 1.
For more on the Compose file format versions, see https://docs.docker.com/compose/compose-file/

I am a newbie with respect to docker, This is the first time I've tried to use it.
I think docker is correctly installed. I can run "sudo docker run hello-world" and get many encouraging lines of output including:
Hello from Docker!

rozen@atlas: ~ > docker-compose -v
docker-compose version 1.29.2, build unknown
Attachments
env.zip
Configuration files.
(4.31 KiB) Downloaded 20 times
IrPBoAgWx10uFO
Posts: 1
Joined: Wed Jun 15, 2022 5:48 pm

Re: Problem with docker-compose installation on Linux Mint

Post by IrPBoAgWx10uFO »

Hi

please note that your Docker Compose version is outdated. Current version is 2.6.0.
Go to https://github.com/docker/compose/releases/tag/v2.6.0

Good luck.
rozen
Posts: 2
Joined: Mon Jun 06, 2022 2:45 am
Location: Point arena, CA

Re: Problem with docker-compose installation on Linux Mint

Post by rozen »

Thank you very much, Switching to the current version of docker-compose got me through the installation process.

I assume that since mayan EDMS is a webapp and that I want to run it as a personal files cabinet on my personal machine, I will need a web server on my personal machine. To that end, I installed apache2. However, when I attempted to run apache there was a clash over port 80. Kill mayan and apache2 works as expected.

So my questions are:
1. Am I on the right track wanting to access mayan through my local web server - apache 2?
2. How do I connect mayan to my apachie2 server?

Any help is greatly appreciated,

Don
Post Reply