Mayan refused to connect when upgrading 4.0.15 to 4.1

When things don't work as they should.
Post Reply
duyhung
Posts: 7
Joined: Mon Jun 07, 2021 11:50 am

Mayan refused to connect when upgrading 4.0.15 to 4.1

Post by duyhung »

Hi there

I am installing mayan on my Debian 4.19.181-1 (2021-03-19) x86_64 server, using Docker.
Before, I used the simple installation method to upgrading, and everything worked fine.

However, with the new 4.1 version, when I was upgrading (bystoped, removed, pull new version and start again), there is ERROR_CONNECTION_REFUSED and I can not access the site.
ERR_CONNECTION_REFUSED.png
ERR_CONNECTION_REFUSED.png (45.95 KiB) Viewed 93 times
I rechecked the firewall and connection but find no problem.
By checking the container list, all seems OK, too.
container list.png
container list.png (12.32 KiB) Viewed 93 times
On stackoverflow, there is a thread with similar problem but also no conclusion on answer (though Mr. Roberto Rosario edited it, too)
https://stackoverflow.com/questions/572 ... ean-server

Hope you please support us to resolve it.
Thanks,
User avatar
rosarior
Developer
Developer
Posts: 683
Joined: Tue Aug 21, 2018 3:28 am
Location: Puerto Rico
Contact:

Re: Mayan refused to connect when upgrading 4.0.15 to 4.1

Post by rosarior »

In a previews post you mentioned using Mayan on port 81 due a conflict with another program. Mayan appears to be running on port 80 in you installation now.

Check the logs using docker-compose logs -f this will tell if Mayan started up correctly or if there was an error booting up (wrong database/broker/results credentials, port conflicts, etc).
Post Reply