Broken 3.1.10 Docker update?

When things doesn't work as they should.
Post Reply
gargantvan
Posts: 16
Joined: Thu Sep 06, 2018 10:57 pm

Broken 3.1.10 Docker update?

Post by gargantvan » Tue May 07, 2019 9:37 pm

Hi

I just pulled the latest image for Docker and I restarted the container, now I am unable to access the page. I have Postres running beside Docker version. I checked the container logs I see these not sure if they are important.

Naturally this was just wokring fine prior to pulling the image. I belive I was using 3.1.7 before.

Code: Select all

1:34:22 +0000] [253] [INFO] Worker exiting (pid: 253)


[2019-05-07 21:34:22 +0000] [266] [INFO] Booting worker with pid: 266


[2019-05-07 21:34:22 +0000] [267] [INFO] Booting worker with pid: 267


[2019-05-07 21:34:52 +0000] [28] [CRITICAL] WORKER TIMEOUT (pid:266)


[2019-05-07 21:34:52 +0000] [28] [CRITICAL] WORKER TIMEOUT (pid:267)


[2019-05-07 21:34:52 +0000] [266] [INFO] Worker exiting (pid: 266)


[2019-05-07 21:34:52 +0000] [267] [INFO] Worker exiting (pid: 267)


[2019-05-07 21:34:52 +0000] [277] [INFO] Booting worker with pid: 277


[2019-05-07 21:34:52 +0000] [278] [INFO] Booting worker with pid: 278


[2019-05-07 21:35:22 +0000] [28] [CRITICAL] WORKER TIMEOUT (pid:277)


gargantvan
Posts: 16
Joined: Thu Sep 06, 2018 10:57 pm

Re: Broken 3.1.10 Docker update?

Post by gargantvan » Tue May 07, 2019 10:28 pm


gargantvan
Posts: 16
Joined: Thu Sep 06, 2018 10:57 pm

Re: Broken 3.1.10 Docker update?

Post by gargantvan » Tue May 07, 2019 10:31 pm

I also stopped 3.1.10 and started 3.1.7 and Mayan is back. So think there is something broken about the 3.1.10 Docker


This is the 3.1.7 version I seem to have

Code: Select all

Mayan EDMS
Version 3.1.7
Build number: v3.1.7_Sun Oct 14 03:51:25 2018 -0400

gargantvan
Posts: 16
Joined: Thu Sep 06, 2018 10:57 pm

Re: Broken 3.1.10 Docker update?

Post by gargantvan » Sat May 11, 2019 9:16 pm

Any ideas? I am totally clueless about why this is happening :(

User avatar
rosarior
Posts: 231
Joined: Tue Aug 21, 2018 3:28 am

Re: Broken 3.1.10 Docker update?

Post by rosarior » Sun May 19, 2019 6:59 pm

We are investigating this behavior. We have only been able to replicate it on Raspberry Pi computers with 512MB of memory. As the message provided by Gunicorn is very sparse debugging has been slow. What OS, hardware (CPU, RAM) are you using?

Post Reply