Search Topic not working anymore after update

Anything concerning integration via the REST API
Post Reply
Bastian
Posts: 15
Joined: Tue Dec 04, 2018 6:18 pm

Search Topic not working anymore after update

Post by Bastian »

Hi @all,

I've updated my Mayan edms to 3.4.13
and I found out that I think several versions ago the API got some severe changes.

the api calls I'm using are not working anymore

In older versions I was able to check if a cabinet exists using this:

but not this only gives me a 404

when I check the api documentation at
in the json reply the search items seems disabled
{
"label": "search",
"url": null
},
but I never manually disabled it.

So this breaking change broke my integration into my CRM to automatically synchronize the documents to Mayan :roll:

Now I try to get back the search topic or at least modify my queries so that it will work again.

In the changelog for Version 3.3 I found that it's possible to disable the simple search
but I don't know if this is relevant here

https://docs.mayan-edms.com/releases/3.3.html
Search

It is now possible to disable the simple search via the new SEARCH_DISABLE_SIMPLE_SEARCH setting.
So what do I need to do to get back the same functionality as I had before?


Best regards
Bastian
Bastian
Posts: 15
Joined: Tue Dec 04, 2018 6:18 pm

Re: Search Topic not working anymore after update

Post by Bastian »

Update 1: searching for documents in that way works...

but not for cabinets

Update 2:

ok so I found out that there was a change in the naming convention - but why and when?
Searching the changelog I found nothing explicit pointing in this direction...

http://edms.local:8000/api/search/cabin ... bel=K02856
Bastian
Posts: 15
Joined: Tue Dec 04, 2018 6:18 pm

Re: Search Topic not working anymore after update

Post by Bastian »

So it seems as I have solved my problem just by noting down the process here :ugeek:

So if anyone else runs into the same problem - the solution is stated above.
Post Reply