File size upload limit

When things don't work as they should.
Post Reply
mpleam
Posts: 22
Joined: Fri Mar 06, 2020 6:58 am

File size upload limit

Post by mpleam »

Hi

I am having problems uploading files larger than around 200Mb to Mayan. Files below this size all seem to upload correctly, but larger fil;es (for example a ~500Mb zip file) start to upload, get about half-way, restart downloading again and then fail at the same midpoint.

The error message doesn't mean much to me, it just says:

`Server responded with 0 code`

Is the file size upload and timeout limit a function of Mayan, the Webserver (in this case Apache 2), PHP or something else? My max file upload size in PHP is 1024Mb. Can anyone shed any light on this? I really need to have the ability to upload quite large files.

Thanks

Mark
User avatar
michael
Developer
Developer
Posts: 135
Joined: Sun Apr 19, 2020 6:21 am

Re: File size upload limit

Post by michael »

Hello,

Currently there are no hard-coded size limits in the code. Size limits can be enabled using quotas.

Mayan does not use PHP but Python. Neither Apache not NGINX are used to server content, a Python application server named Gunicorn is used instead. If you added Apache as a reverse proxy, then that could be a place where a default size limit could be the root cause.

However, HTTP errors 431 and 413 are usually returned when the file being transmitted is too large. In this case the 0 code error seems to indicate that the Mayan Gunicorn server process either died (too little memory or CPU shares, Linux OOM killer kicked in) or a timeout happened. The default timeout for HTTP requests is 120 seconds.

Try increasing the Gunicorn timeout and/or adding more memory for the installation.
mpleam
Posts: 22
Joined: Fri Mar 06, 2020 6:58 am

Re: File size upload limit

Post by mpleam »

Hello Michael

Thank you for your prompt response.
Try increasing the Gunicorn timeout and/or adding more memory for the installation.
That did the trick! I had to increase the timeout to 600 seconds (to allow upload of larger files).

Thank you again

Mark
Post Reply