Index not updating automatically

When things don't work as they should.
Post Reply
springpole
Posts: 3
Joined: Tue Dec 15, 2020 1:16 am

Index not updating automatically

Post by springpole »

I am currently experiencing an issue with indexing where it does not seem to update automatically.

The setup is currently as follows:

Mayan Version:
- Version 3.4.10 Build number: v3.4.10_Wed Jun 24 03:32:35 2020 -0400

Workflow:
- Several states, one to attach a "For Review" tag on entry, transitions to the state that attaches "Pending" tag, which transitions to the state that attaches "Approved" tag.
- Number of different document types associated with this workflow is at around 40+, and currently totals to about 235 documents.

Other Documents:
- Total number of documents in Mayan: 9,180
- Total number of pages in Mayan: 107,697

Index:
- Parent with one child:
{% if "Pending" in document.tags.all.values_list|join:"" %} Pending {% endif %} //Documents can have more than 1 tag.


The workflow works and is able to attach and remove tags properly. However, when a "Pending" tag is attached, the index associated is not updated automatically. Sometimes, 5 documents get moved to "Pending" but only 2 appear in the index. Sometimes 10 get moved from "Pending" to "Approved" and none get removed from the "Pending" index. Even after 24h, the results are still the same.

COMMON_PRODUCTION_ERROR_LOGGING is enabled and error.log does not seem to contain any errors.

I've tried the same setup on a different Mayan installation with a significantly lower volume of documents and the index seems to update automatically. Is the number of documents the factor?
Post Reply