Page 1 of 1

Fresh install 3.4.7 on Debian10 - Documents not visible !

Posted: Wed May 13, 2020 12:34 am
by kozmi
Hi Guys
and thanks in advance for your time reading my message!

I tried to install the latest version 3.4.7 on Debian 10 and the process went ok without any error.
This is the first time for me trying the Mayan EDMS and I'm facing a strange issue. I tried many types of documents txt,pdf,jpeg,doc ,but none of them can be displayed.

I searched for the presence of any error in /var/log/supervisor/ ,but it looks everything is working ok.
Can you please someone of you help me with this issue?

Thanks a lot !

Hi guys,
After struggling many hours I have decided to rebuild it again and now it works as expected. :D
I have to learn now how to use it.

Thanks !

Re: Fresh install 3.4.7 on Debian10 - Documents not visible !

Posted: Mon May 18, 2020 4:20 pm
by myersvandalay
Can you explain what you mean by rebuilding?...


I'm on ubuntu 20.04 and think I may be running into the same problem... it acts like everything is working at a glance, but every type of file's previews and thumbnails are red X's, and I can't find any reason why

Re: Fresh install 3.4.7 on Debian10 - Documents not visible !

Posted: Wed May 20, 2020 8:58 pm
by buddylindsey
This is totally my issue as well.

I am trying to use it with s3 storage backend as well.

The error I get is:

Code: Select all

'NoneType' object has no attribute 'size'
from here
mayan/apps/converter/transformations.py in execute_on at line 93

Code: Select all

    def execute_on(self, image):
        self.image = image
        self.aspect = 1.0 * image.size[0] / image.size[1]
Literally stuff is uploading and the files are named with the uuid properly in the storage location. I can even download the file add the .jpg extension and it reads fine.

It is like something is not working right with caching, maybe.

Re: Fresh install 3.4.7 on Debian10 - Documents not visible !

Posted: Thu May 21, 2020 4:23 pm
by buddylindsey
So I solved my issue.

I was trying to store the document_cache in s3, and it wasn't working. It would create the base cache file in s3, but it was 0 bytes 🤷🏼‍♂️.

I eventually changed it back to the filesystem storage and am using AWS EFS to store the cache files so they can be shared across servers/processes.

Re: Fresh install 3.4.7 on Debian10 - Documents not visible !

Posted: Mon May 25, 2020 12:47 pm
by kozmi
myersvandalay wrote:
Mon May 18, 2020 4:20 pm
Can you explain what you mean by rebuilding?...


I'm on ubuntu 20.04 and think I may be running into the same problem... it acts like everything is working at a glance, but every type of file's previews and thumbnails are red X's, and I can't find any reason why
By rebuilding I mean to install it again from scratch.