[solved] Staging folders error

When things don't work as they should.
Post Reply
User avatar
dwegrzyn
Posts: 4
Joined: Wed Apr 15, 2020 12:12 pm

[solved] Staging folders error

Post by dwegrzyn »

Hello everyone! :)

I have a problem with staging (watch) folders in Mayan EDMS (version 3.3.16 on docker, Debian).

During executing this command:
docker run mayan-edms -v /opt/scanned_files:/scanned_files mayanedms/mayanedms:latest
I receive such error:
Unable to find image 'mayan-edms:latest' locally
docker: Error response from daemon: pull access denied for mayan-edms, repository does not exist or may require 'docker login': denied: requested access to the resource is denied.
See 'docker run --help'.
I also tried to stop the container but the error is still the same.

How to run a container with access to outside data?


=====================update============================
this solution helped:

mkdir /mnt/scans
docker exec -it mayan-edms bash
mkdir /mnt/scans
exit
docker stop mayan-edms
docker rm mayan-edms
docker run \
-d \
--name mayan-edms \
--restart=always \
-p 80:8000 \
-e MAYAN_DATABASES="{'default':{'ENGINE':'django.db.backends.postgresql','NAME':'mayan','PASSWORD':'mayanuserpass','USER':'mayan','HOST':'172.17.0.1'}}" \
-e MAYAN_CELERY_BROKER_URL="redis://:mayanredispassword@172.17.0.1:6379/0" \
-e MAYAN_CELERY_RESULT_BACKEND="redis://:mayanredispassword@172.17.0.1:6379/1" \
-v /docker-volumes/mayan-edms/media:/var/lib/mayan \
-v /mnt/scans:/mnt/scans \
mayanedms/mayanedms:3.4.5

Post Reply