document new version upload error

When things don't work as they should.
Post Reply
BlackGuardian_AR
Posts: 4
Joined: Tue Mar 03, 2020 2:38 pm

document new version upload error

Post by BlackGuardian_AR »

Greetings to all

I am having problems in my Mayan EDMS installation. Just in case, I took the trouble to install a new clean version of Mayan on another PC .. and I get the same error. The installation method tested is through Simple Docker and Docker Compose (both) ... version 3.4.4.

The problem occurs when I want to upload a new document version, I get the following error in error.log

2020-04-11 20:48:04,022 mayan.apps.common.middleware.error_logging <322> [ERROR] "process_exception() line 17 ^[[31;1mException caught by request middleware; <WSGIRequest: GET '/sources/documents/745/versions/u$
Traceback (most recent call last):
File "/opt/mayan-edms/lib/python3.7/site-packages/django/core/handlers/base.py", line 113, in _get_response
response = wrapped_callback(request, *callback_args, **callback_kwargs)
File "/opt/mayan-edms/lib/python3.7/site-packages/django/views/generic/base.py", line 71, in view
return self.dispatch(request, *args, **kwargs)
File "/opt/mayan-edms/lib/python3.7/site-packages/mayan/apps/sources/views.py", line 375, in dispatch
klass=Document, pk=kwargs['document_id']
KeyError: 'document_id'
error2.png
error2.png (43.83 KiB) Viewed 1246 times
HTOP screen shot
error1.png
error1.png (68.64 KiB) Viewed 1246 times

Could you tell me what's going on?
It should be noted that I tried with persistent volumes (option -v) and without them, just in case ... but I have been testing for hours and I have no results ...

The line in HTOP that says -Q ERROR .... its ok? because this line appears all time in a fresh deploy...


greetings and thanks!

Post Reply