Page 1 of 1

now trying 3.3.13 from 3.2.11 error: "need to install postgresql-server-dev-X.Y"

Posted: Wed Feb 19, 2020 9:50 pm
by solano2
Similar error when trying to follow steps for latest 3.3.13 at step 6 of:

"Upgrading from Mayan EDMS 3.2.x" from here:

https://docs.mayan-edms.com/releases/3.3.13.html#


sudo -u mayan /opt/mayan-edms/bin/pip install --no-use-pep517 psycopg2==2.8.3 redis==3.3.11
Collecting psycopg2==2.8.3
Using cached psycopg2-2.8.3.tar.gz (377 kB)
ERROR: Command errored out with exit status 1:
command: /opt/mayan-edms/bin/python3 -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-vdsu8jff/psycopg2/setup.py'"'"'; __file__='"'"'/tmp/pip-install-vdsu8jff/psycopg2/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-install-vdsu8jff/psycopg2/pip-egg-info
cwd: /tmp/pip-install-vdsu8jff/psycopg2/
Complete output (7 lines):
running egg_info
creating /tmp/pip-install-vdsu8jff/psycopg2/pip-egg-info/psycopg2.egg-info
writing /tmp/pip-install-vdsu8jff/psycopg2/pip-egg-info/psycopg2.egg-info/PKG-INFO
writing dependency_links to /tmp/pip-install-vdsu8jff/psycopg2/pip-egg-info/psycopg2.egg-info/dependency_links.txt
writing top-level names to /tmp/pip-install-vdsu8jff/psycopg2/pip-egg-info/psycopg2.egg-info/top_level.txt
writing manifest file '/tmp/pip-install-vdsu8jff/psycopg2/pip-egg-info/psycopg2.egg-info/SOURCES.txt'
Error: b'You need to install postgresql-server-dev-X.Y for building a server-side extension or libpq-dev for building a client-side application.\n'
----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.

Re: now trying 3.3.13 from 3.2.11 error: "need to install postgresql-server-dev-X.Y"

Posted: Wed Feb 19, 2020 9:54 pm
by solano2
May be solved (got past the error) by doing the following:

Code: Select all

sudo apt-get install postgresql
(was already installed, nothing to do)
Then...

Code: Select all

sudo apt-get install python-psycopg2
Then...

Code: Select all

sudo apt-get install libpq-dev
Finally I run again step 6 and it was successfull:

Code: Select all

sudo -u mayan /opt/mayan-edms/bin/pip install --no-use-pep517 psycopg2==2.8.3 redis==3.3.11
This is on ubuntu 18.04 LTS

Re: now trying 3.3.13 from 3.2.11 error: "need to install postgresql-server-dev-X.Y"

Posted: Wed Feb 19, 2020 10:21 pm
by solano2
Yeah that seems to have resolved it. I was able to get 3.3.13 upgrade from 3.2.11.

However....

3.3.13 seems very slow though (logo wheel constantly spinning) and slow loading between pages.

It could be that it's regenerating document thumbnails or something here. We only have 175 docs, but they are mostly big pdf drawings.