[SOLVED] upload document error with mayan 3.3.8 frsh install on ubuntu 18.04

When things don't work as they should.
Post Reply
bixmatech
Posts: 9
Joined: Tue Nov 26, 2019 6:35 pm

[SOLVED] upload document error with mayan 3.3.8 frsh install on ubuntu 18.04

Post by bixmatech »

Hello,
I installed on a pc ubuntu 18.04 then I deployed mayan on port 81 using docker method with these commands:

Code: Select all

curl -fsSL get.mayan-edms.com -o get-mayan-edms.sh
INSTALL_DOCKER=true sh get-mayan-edms.sh
docker run -p 81:8000 -dit --restart always mayanedms/mayanedms
And now I am able to browse mayan via http://localhost:81 and I see that it is the last version Build number: v3.3.8_Fri Jan 17 04:03:05 2020 -0400, when I try to uplaod a document it shows error with 0 code, attached screenshot
ANy idea how to solve that?
Attachments
2019-12-14_22-15-42.png
2019-12-14_22-15-42.png (48.88 KiB) Viewed 85 times

User avatar
rssfed23
Moderator
Moderator
Posts: 185
Joined: Mon Oct 14, 2019 1:18 pm
Location: United Kingdom
Contact:

Re: upload document error with mayan 3.3.8 frsh install on ubuntu 18.04

Post by rssfed23 »

Hi Bixmatech.

What does the output of "docker ps" show you?

As I notice you're running the script and then running the Mayan container manually afterwards. I don't think that will work as the script itself launches mayan in the background on port 80 and now you've launched a second instance of mayan on port 81 that won't be connected to the database/redis etc. If you try http://localhost (so port 80) does that work?
Please don't PM for general support; start a new thread with your issue instead.

bixmatech
Posts: 9
Joined: Tue Nov 26, 2019 6:35 pm

Re: upload document error with mayan 3.3.8 frsh install on ubuntu 18.04

Post by bixmatech »

Thank you rssfed23, you are right, I removed it then reinstalled it without manually run it and it works :)

User avatar
rssfed23
Moderator
Moderator
Posts: 185
Joined: Mon Oct 14, 2019 1:18 pm
Location: United Kingdom
Contact:

Re: upload document error with mayan 3.3.8 frsh install on ubuntu 18.04

Post by rssfed23 »

Pleased to hear :)
Please don't PM for general support; start a new thread with your issue instead.

Post Reply