[SOLVED] No port assigned to Mayan container

When things don't work as they should.
Post Reply
tabunon
Posts: 12
Joined: Wed Aug 14, 2019 4:35 am

[SOLVED] No port assigned to Mayan container

Post by tabunon »

Hello,

After days, I'm still pondering on Mayan EDMS to be accessed and working.

However, I came across the some issues.

1. No port assigned after running this command:

Code: Select all

docker run -d --name mayan-edms --restart=always -p 80:8000 -e MAYAN_DATABASE_ENGINE=django.db.backends.postgresql -e MAYAN_DATABASE_HOST=172.17.0.1 -e MAYAN_DATABASE_NAME=mayan -e MAYAN_DATABASE_PASSWORD=mayanuserpass -e MAYAN_DATABASE_USER=mayan -v /docker-volumes/mayan-edms/media:/var/lib/mayan mayanedms/mayanedms:latest

Port 8000 on the Mayan container should be opened and bridged to port 80 of the host IP.


2. Checking on docker port assignments:

Code: Select all

[root@mayan-corp mayan]# docker ps
CONTAINER ID        IMAGE                        COMMAND                  CREATED             STATUS                          PORTS                    NAMES
8e0f679dbc07        mayanedms/mayanedms:latest   "entrypoint.sh mayan"    38 minutes ago      Restarting (1) 45 seconds ago                            mayan-edms
7d7f6a9bb2df        postgres:9.6                 "docker-entrypoint.s…"   4 hours ago         Up 2 hours                      0.0.0.0:5432->5432/tcp   mayan-edms-postgres

3. This confirms from the browser:
noAccess.png
noAccess.png (18.57 KiB) Viewed 459 times

4. I opened port 80 on the host and Mayan is still inaccessible:

Code: Select all

[root@mayan-corp mayan]# firewall-cmd --list-all
public (active)
  target: default
  icmp-block-inversion: no
  interfaces: em1
  sources: 
  services: dhcpv6-client ssh
  ports: 8000/tcp 80/tcp
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 

Any advise on what needs to be done so Mayan EDMS can be accessible.

Any help will be greatly appreciated.

Thank you.
Last edited by tabunon on Fri Sep 27, 2019 1:19 am, edited 1 time in total.

tabunon
Posts: 12
Joined: Wed Aug 14, 2019 4:35 am

Re: No port assigned to Mayan container

Post by tabunon »

Resolved.

TCP ports are not initially open; prior to installation, planned port assignments should be configured open.

Post Reply