Start Errors after update

When things don't work as they should.
Post Reply
pace
Posts: 2
Joined: Tue May 18, 2021 9:29 am

Start Errors after update

Post by pace »

Since updating to version 4, I can no longer start the services through docker-compose.

Code: Select all

Starting mayan_redis_1      ... error
Starting mayan_postgresql_1 ... 

ERROR: for mayan_redis_1  Cannot start service redis: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: process_linux.go:508: setting cgroup config for procHooks process caused: cannot fetch program from id: get programStarting mayan_postgresql_1 ... error

ERROR: for mayan_postgresql_1  Cannot start service postgresql: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: process_linux.go:508: setting cgroup config for procHooks process caused: cannot fetch program from id: get program by id: permission denied: unknown

ERROR: for redis  Cannot start service redis: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: process_linux.go:508: setting cgroup config for procHooks process caused: cannot fetch program from id: get program by id: permission denied: unknown

ERROR: for postgresql  Cannot start service postgresql: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: process_linux.go:508: setting cgroup config for procHooks process caused: cannot fetch program from id: get program by id: permission denied: unknown
ERROR: Encountered errors while bringing up the project.
RobertVib
Posts: 6
Joined: Wed Mar 31, 2021 11:27 pm

Re: Start Errors after update

Post by RobertVib »

I got the same error after updating Fedora. The error has nothing to do with Mayan.

https://www.reddit.com/r/Fedora/comment ... st_update/
Post Reply