Installation troubles

When things doesn't work as they should.
Post Reply
stevemgrimes
Posts: 7
Joined: Sat Jun 01, 2019 10:43 pm
Location: San Bernardino, CA
Contact:

Installation troubles

Post by stevemgrimes » Wed Jun 05, 2019 4:31 pm

Hello:

I'm having a terrible time getting Mayan up and running for a first-time demo.

I'm running a CENTOS computer, and have installed /tested Docker (using their "Hello World" container example), and followed the rest of the installation directions carefully. It appears that everything is installing correctly, but I don't seem to have a working webserver to start with. After finding a post in the forum stating that someone had a problem installing the current version, I tried downloading and running the prior version he mentioned, but got same results.

Here's what I see, viewing the container list:
$ docker container ls
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
802e2d5e5d85 mayanedms/mayanedms:3.1.7 "entrypoint.sh mayan" 23 hours ago Restarting (1) 4 seconds ago mayan-edms
d9bf3e2c7c26 postgres:9.5 "docker-entrypoint.s…" 23 hours ago Up 23 hours 0.0.0.0:5432->5432/tcp mayan-edms-postgres

I've opened a browser on that machine and tried entering several url's, to no avail (http://localhost, http://<actual ip of CENTOS box>, http://172.17.0.1, and others). Also tried connecting to the computer name and IP from a browser on my other Windows machine.

Any help would be most appreciated, as I'm very anxious to get a running example so that I can discuss possibly using Mayan to convert to from our AppXtender system.

Thank you
Steve Grimes
Business Systems Analyst
Inland Regional Center
San Bernardino, CA

User avatar
rosarior
Posts: 345
Joined: Tue Aug 21, 2018 3:28 am

Re: Installation troubles

Post by rosarior » Wed Jun 05, 2019 4:52 pm

Hi,

what are the Docker and the CENTOS kernel version and distribution version? We've are finding increasing Docker issues with some kernel versions that are not related to Mayan. Some incompatible setting have been introduced with regards of the overlayfs and metacopy features used by Docker and Linux some distributions have not catched up yet.

https://docs.mayan-edms.com/topics/trou ... tml#docker

stevemgrimes
Posts: 7
Joined: Sat Jun 01, 2019 10:43 pm
Location: San Bernardino, CA
Contact:

Re: Installation troubles

Post by stevemgrimes » Wed Jun 05, 2019 5:40 pm

Thanks for the prompt reply - version info follows. Please let me know if there's anything I'm missing.

For CENTOS kernel:
$ uname -r
3.10.0-957.5.1.el7.x86_64

CENTOS distribution:
$ cat /etc/centos-release
CentOS Linux release 7.6.1810 (Core)

Docker:
$ docker -v
Docker version 18.09.6, build 481bc77156
Steve Grimes
Business Systems Analyst
Inland Regional Center
San Bernardino, CA

stevemgrimes
Posts: 7
Joined: Sat Jun 01, 2019 10:43 pm
Location: San Bernardino, CA
Contact:

Re: Installation troubles

Post by stevemgrimes » Mon Jun 10, 2019 4:55 pm

Hi - any help on this would be much appreciated. I am most anxious to get this running, so that I can work with my IT team to see if it's a viable solution for us to pursue.

Thanks!
Steve Grimes
Business Systems Analyst
Inland Regional Center
San Bernardino, CA

fafamonge
Posts: 1
Joined: Tue Jun 25, 2019 2:45 pm

Re: Installation troubles

Post by fafamonge » Tue Jun 25, 2019 2:48 pm

I have exactly the same error with the same software version.

I followed the instructions of installation guide, I have the containers running but no access from my host's ip.

User avatar
rosarior
Posts: 345
Joined: Tue Aug 21, 2018 3:28 am

Re: Installation troubles

Post by rosarior » Wed Jun 26, 2019 2:54 am

@fafamonge Is there any debug information that you can share that could help us pinpoint the issue?
If using Docker, do:

Code: Select all

docker logs -f <Mayan EDMS container>

Post Reply