Page 1 of 1

Mayan on Synology 918+

Posted: Fri Feb 08, 2019 10:02 pm
by Kdrums
Hello,

I'm messing around with setting up Mayan on a Synology 918+.
I'd say i'm far from versed in the arts of virtualization, docker and the likes, and even my experience with Synology's DSM is fresh.
What I did until now is I downloaded and installed Docker on Synology, download and installed the Mayan image from the Registry section, ran it successfully, but I can't seem to access it.

Any help or pointer in the right direction would be greatly appreciated.
Thank you.

Re: Mayan on Synology 918+

Posted: Sun Feb 10, 2019 5:27 pm
by jevgl
Hi,
i've spent half a day on the exact same issue, and the same model.

gave up and build a VM on VMM using ubuntu. On the Mayan wiki youll find a quick how to with all the commands and you should get the thing up and running in 20 minutes.

Re: Mayan on Synology 918+

Posted: Sun Feb 24, 2019 8:08 pm
by koen
I'm just new to this forum and mayan, and initially I also had troubles finding Mayan after succesfull setup on the same NAS:

In my case, after starting the container in DSM, some random port was assigned to the container (a new one for every restart even). The port is specified when you look at the details for this container in the docker app in DSM.

Whitout the container running you can set a fixed port in the container settings and restart.

Though a bit late you could give it a try, it might still be an easier solution than the DIY setup...

addition:
And since you might even be more inexperienced in all this than I am;

with port I mean the <number> following your NAS IP-address or host name when accessing Mayan in your browser

URL: 192.168.0.2:<number>

Re: Mayan on Synology 918+

Posted: Mon Feb 25, 2019 11:48 am
by KevinPawsey
you are correct Koen, you need to "map" a port from the real-world IP address of your NAS to the internal port in the Docker image... in this case it is 8000. I would assume that if you just type in

Code: Select all

http://[your NAS IP]
to get to the management address of the NAS, do not use port 80, as in the documentation. This is because the NAS management is already using that port number, and the ports can't be shared. I would suggest using a different port (8000, 8080, even 81) and then access it with

Code: Select all

http://[your NAS IP]:[port chosen]
Anyway, hope that helps.

Kevin