Mayan 2.7 on Debian Document Cache is filling up the hard disk

Questions, comments, discussions. Over time certain topics might be moved to their own category.
Post Reply
tushar
Posts: 4
Joined: Tue Jan 29, 2019 7:00 am

Mayan 2.7 on Debian Document Cache is filling up the hard disk

Post by tushar » Tue Jan 29, 2019 7:37 am

I have installed Mayan 2.7. The document cache was using 29 GB space so I cleared document image cache and the restarted the server.

The cache dropped down to 0.

Now mayan is recreating all those files and is back to 800MB. Also using the full CPU

Thanks

tushar
Posts: 4
Joined: Tue Jan 29, 2019 7:00 am

Re: Mayan 2.7 on Debian Document Cache is filling up the hard disk

Post by tushar » Tue Jan 29, 2019 12:04 pm

I have now changed

DOCUMENTS_DISABLE_BASE_IMAGE_CACHE to True
and also
DOCUMENTS_DISABLE_TRANSFORMED_IMAGE_CACHE to True

I can see that in System - Setup - Settings - Documents

The cache files are still getting created

User avatar
rosarior
Posts: 284
Joined: Tue Aug 21, 2018 3:28 am

Re: Mayan 2.7 on Debian Document Cache is filling up the hard disk

Post by rosarior » Tue Jan 29, 2019 3:42 pm

Setting DOCUMENTS_DISABLE_BASE_IMAGE_CACHE and DOCUMENTS_DISABLE_TRANSFORMED_IMAGE_CACHE to True should disable all caching, please restart all the processes to make sure the setting is not being cached. Also check the config.yml file to make sure the settings are set to True there too. The config.yml file uses the YAML format, this means that if it is edited by hand the value for True is lowercase true as opposed to uppercase True for Python.

Starting from the next release (4.0) we've added a dedicated app to handle caching. This app trims the cache automatically based on disk usage limits via a new DOCUMENTS_CACHE_MAXIMUM_SIZE setting.

Cache manager commits:
https://gitlab.com/mayan-edms/mayan-edm ... f19c144e6b
https://gitlab.com/mayan-edms/mayan-edm ... 6cb2958764
https://gitlab.com/mayan-edms/mayan-edm ... 59de19b531

tushar
Posts: 4
Joined: Tue Jan 29, 2019 7:00 am

Re: Mayan 2.7 on Debian Document Cache is filling up the hard disk

Post by tushar » Wed Jan 30, 2019 11:30 am

I am on 2.7 version so I think there is no config.yml in the media folder. Correct me if I am wrong

The settings from the menu says true for both DOCUMENTS_DISABLE_BASE_IMAGE_CACHE and DOCUMENTS_DISABLE_TRANSFORMED_IMAGE_CACHE

Is there a queue for OCR or Document Cache in some table in the database. I can check if there is something there.

Thanks

Post Reply