Disable macros in office docs

Questions, comments, discussions. Over time certain topics might be moved to their own category.
Post Reply
nusonamin
Posts: 1
Joined: Sun Oct 28, 2018 2:19 am

Disable macros in office docs

Post by nusonamin » Mon Oct 29, 2018 5:18 pm

We have some documents with macros that execute when opened and increase a counter. Accessing these documents in Mayan triggers the macros and makes the counters go up. It is possible to disable macro execution? Thanks.

User avatar
rosarior
Posts: 159
Joined: Tue Aug 21, 2018 3:28 am

Re: Disable macros in office docs

Post by rosarior » Tue Oct 30, 2018 3:40 am

We had a previous report of something similar but have not been able to duplicate this behavior. Macros are not executed during conversion and the real cause was an auto update date field. If you could share the document in question or a similar one with the same behavior we could get to the bottom of the cause you are experiencing and add code to mitigate if possible.

theintelligentmouse
Posts: 5
Joined: Thu Nov 01, 2018 7:16 am

Re: Disable macros in office docs

Post by theintelligentmouse » Thu Nov 01, 2018 7:23 am

Hello,

Yes we experience the same issue.

The data field on old documents has been set to auto update and it does this when the document is opened by Mayan it would seem.

These documents are from the mostly from the 90s and include an old macro type, recent copies of Office prevent from running and show the usual yellow warning bar.

I will try and get a sample document which doesn't contain confidential data.

Thanks

User avatar
rosarior
Posts: 159
Joined: Tue Aug 21, 2018 3:28 am

Re: Disable macros in office docs

Post by rosarior » Mon Nov 05, 2018 5:18 am

An example document would go a long in helping solve this, thank you!

theintelligentmouse
Posts: 5
Joined: Thu Nov 01, 2018 7:16 am

Re: Disable macros in office docs

Post by theintelligentmouse » Sun Nov 11, 2018 9:52 pm

Hello,

I created a document with various date fields with the option of auto update enabled.

Upon uploading the document to Mayan the document is processed and the date time with seconds gets updated and therefore the integrity of the data is compromised.

Can it be that the document is opened by the auto update fields are not processed?

For example, if this is a quote, invoice or specification the date needs to stay intact.

Many Thanks,
Attachments
New Microsoft Word Document.zip
date field update
(10.4 KiB) Downloaded 6 times

Post Reply