Version 3.3.18

Post Reply
User avatar
rosarior
Developer
Developer
Posts: 655
Joined: Tue Aug 21, 2018 3:28 am
Location: Puerto Rico
Contact:

Version 3.3.18

Post by rosarior »

Released March 13, 2021

Status: End of life

Please read the release notes before upgrading: https://docs.mayan-edms.com/releases/3.3.18.html

Package locations

Docker image available at: https://hub.docker.com/r/mayanedms/mayanedms

Python packages available at: https://pypi.org/project/mayan-edms/3.3.18/ and installed via:

Code: Select all

pip install mayan-edms==3.3.18

The purpose of this version is to help users migrating from version prior to series 3.3 and from custom version of the 3.3 series.

Changes

Dependencies

Updated the Transifex client to version 0.13.7. Version 0.13.6 appears to have been deleted, this caused the build scripts to stop working.

Recent changes to the Cryptography library require the Rust language as a build time dependency unless a recent version of PIP is used. The build script will now use PIP version 21.0.1 to accomplish this.

File metadata

Migration 0003 of the File metadata was optimized to reduce time and memory usage.

GitLab CI

Improvements from more recent version were backported to allow this series to continue build.

Changes
  • Backport Makefile improvements.

Other

Update contributed LDAP setting file.

Removals
  • None

Backward incompatible changes
  • None

Issues closed
  • None
Post Reply