Version 3.4.8

Post Reply
User avatar
michael
Developer
Developer
Posts: 82
Joined: Sun Apr 19, 2020 6:21 am

Version 3.4.8

Post by michael »

Released: May 25, 2020

Please read the release notes before upgrading: https://docs.mayan-edms.com/releases/3.4.8.html

Package locations

Docker image available at: https://hub.docker.com/r/mayanedms/mayanedms

Python packages available at: https://pypi.org/project/mayan-edms/3.4.8/ and installed via:

Code: Select all

pip install mayan-edms==3.4.8

Changes

Documentation

The link to the installation chapter was fixed in both README files.

Dependencies

The django-qsstats-magic dependency was moved to the app that uses it, the mayan_statistics app.

Some dependencies were updated:
  • Pillow from version 7.0.0 to 7.1.2.
  • Werkzeug from version 1.0.0 to 1.0.1.
  • devpi-server from version 5.4.1 to 5.5.0.
  • django-celery-beat from version 1.5.0 to 2.0.0.

Operating systems

The detection of binaries under OpenBSD 6.7 was improved and added for the parsing app. Binaries under OpenBSD 6.7 are now detected and don\'t require symbolic linking.

Quotas

Pre-creation hooks were added to the document and document version models. These hook are now used by the quotas app to check if the action for these models are valid and raise a quota exceeded error early on before the task is submitted for background processing.

Settings

Django\'s AUTHENTICATION_BACKENDS setting was exposed and is now usable with Mayan\'s configuration system.

User interface

Long texts in the panel\'s body now wrap around. Likewise long tags now also wrap around when shown in a panel\'s body.

Other
  • Move templating to the templating app. No functional changes added only code reorganization for future improvements.
  • Update translation files.
  • Encapsulate actstream registry inside a EventModelRegistry.

Removals
  • None

Backward incompatible changes
  • None

Issues closed
Post Reply