Version 3.3.16

Post Reply
User avatar
rssfed23
Moderator
Moderator
Posts: 213
Joined: Mon Oct 14, 2019 1:18 pm
Location: United Kingdom
Contact:

Version 3.3.16

Post by rssfed23 »

Released: March 17th, 2020

Please read the release notes before upgrading: https://docs.mayan-edms.com/releases/3.3.16.html

Changes:

Documentation

Several minor release notes typographical errors were fixed.

Dependencies

Multiple dependencies were updated following security advisories:

psutil was updated from version 5.6.3 to 5.7.0 due to CVE-2019-18874 (https://nvd.nist.gov/vuln/detail/CVE-2019-18874)
python-gnupg was updated from version 0.3.9 to 0.4.5 due to CVE-2019-6690 (https://nvd.nist.gov/vuln/detail/CVE-2019-6690)
Django was updated from version 1.11.28 to 1.11.29 due to CVE-2020-9402 (https://nvd.nist.gov/vuln/detail/CVE-2020-9402)

Events

An API permission change for the EventList API view was reverted.

OCR

The code and data inside the OCR transaction was reduced. The creation of a file cache entry was also removed from the database transaction. This is an attempted fix GitLab issues #782 and #735.

The OCR model property entry was corrected. It was listed as

Code: Select all

document.content
instead of

Code: Select all

document.ocr_content
.

Removals
None

Package locations:

Please read the release notes before upgrading: https://docs.mayan-edms.com/releases/3.3.16.html

Docker image available at: https://hub.docker.com/r/mayanedms/mayanedms

Python packages available at: https://pypi.org/project/mayan-edms/3.3.16/ and installed via:

Code: Select all

pip install mayan-edms==3.3.16
Please bear with us during the current global situation. The team all have families and local communities to look after as well as the community here. Responses may be delayed during this time, but rest assured we will get to your query eventually.

Post Reply