Version 3.3.6

Post Reply
User avatar
rosarior
Developer
Developer
Posts: 522
Joined: Tue Aug 21, 2018 3:28 am
Location: Puerto Rico
Contact:

Version 3.3.6

Post by rosarior »

Released: December 19, 2019

Changes

Compressed files

Zip files only support UTF-8 and CP437 encoding for filenames. This is not strongly enforced and some software products create Zip files with other text encodings. The ZipArchive class was updated to work with badly encoded filenames instead of raising an error.

Converter

The page count code was updated to work with more versions of PDF files. A Python 3 incompatibility was also fixed.

Documents

The PDF orientation detection was fixed and updated to work with the new converter layer system.

Redis

The Redis lock backend initialization was updated to allow it to also work with Redis versions older than 5.0.

Security

A fix for a cross site scripting issues was removed by accident during a version merge at some unknown time. The fix was reapplied and more robust tests using Selenium added to avoid further regressions.

Settings

FreeBSD is now also detected and the paths of binaries adjusted for easier installation.

Sources

A issue that left behind periodic task entries for watch folders after deleting a document type associated with them was fixed.

Transaction handling was added to the interval sources base class delete and save methods. This increases protection against data loss on database failure.

User interface

The last update for the user interface planned for series 3.3 is included. This update makes the list toolbar “stick” to the top of the view when scrolling. This is the new toolbar that encloses the multi-item action menu and the pagination controls.

The usage of the incorrect word “overrided” was updated to “overridden”.

The address used to check for new versions was updated to the new Python Package Index address. This avoids SSL certificate errors when the old certificate is reused.

Removals

- None



Docker image available at: https://hub.docker.com/r/mayanedms/mayanedms

Python packages available at: https://pypi.org/project/mayan-edms/3.3.6/ and installed via:

Code: Select all

pip install mayan-edms==3.3.6
Release notes: https://docs.mayan-edms.com/releases/3.3.6.html

Post Reply