Version 3.3.4

Post Reply
User avatar
rosarior
Developer
Developer
Posts: 513
Joined: Tue Aug 21, 2018 3:28 am
Location: Puerto Rico
Contact:

Version 3.3.4

Post by rosarior »

Released: December 09, 2019

Celery

Switched from librabbitmq to py-amqp. This library is used to connect to RabbitMQ and be used as the message broker for the background tasks. Although the official documentation still lists librabbitmq, maintainers are recommending users to move to py-amqp.

Converter

Fixed the label display of the transformations. The way the BaseTransformationType metaclass is passed was updated to work on Python 3.

Development

Updated devpi-server version to 5.3.1.

Added targets to run staging containers using RabbitMQ as broker.

Fix docker-runtest-all makefile target.

Frontend

Changed the gunicorn worker class to synchronous. This change was made in the Docker image and is now the worker class for the direct deployment too.

Update the supervisord config file to activate this change. This solves spurious HTTP timeout errors caused by Celery’s new Redis interface not working with threaded serverlets.

File metadata

Add locking to the file metadata document processing task.

Settings

The setting override columns was changed from text to a check mark widget. This makes it clear when a setting is being overridden by an environment variable.

Added icons to the smart settings links.

Fixed the evaluation priority of the bootstrap settings. This issue was causing environment variables to be ignored in favor of config file values on Docker images.

User interface

Darken content area when opening the mobile menu.

Other

Don’t set SourceColumn to the attribute name when no help text is defined.


Docker image available at: https://hub.docker.com/r/mayanedms/mayanedms

Python packages available at: https://pypi.org/project/mayan-edms/3.3.4/ and installable via:

Code: Select all

pip install mayan-edms==3.3.4
Release notes: https://docs.mayan-edms.com/releases/3.3.4.html

Post Reply