staging_folders API doesn't return any staged files [SOLVED]

Anything concerning integration via the REST API
Post Reply
Posts: 3
Joined: Sun Jan 26, 2020 5:37 am

staging_folders API doesn't return any staged files [SOLVED]

Post by BeepDog »

I filed a gitlab issue ( ), because I think it's an actual bug, but I figured I'd cross post here, in case I'm simply doing it wrong.

The gist of it: I should see files in the staging_files API call, as I've got one in the UI. I don't see anything, however. Doesn't make sense.

Here I have a document staged ready for processing:

However my API call doesn't show any files :(

Code: Select all

I, [2020-01-25T23:33:21.629733 #30009]  INFO -- request: GET
D, [2020-01-25T23:33:21.629778 #30009] DEBUG -- request: accept: "application/json"
Authorization: "Token BLERP"
User-Agent: "Faraday v0.17.3"
I, [2020-01-25T23:33:21.654555 #30009]  INFO -- response: Status 200
D, [2020-01-25T23:33:21.654630 #30009] DEBUG -- response: server: "gunicorn/19.9.0"
date: "Sun, 26 Jan 2020 05:33:21 GMT"
connection: "close"
content-type: "application/json"
vary: "Accept, Accept-Language, Origin, Cookie"
content-language: "en"
x-frame-options: "SAMEORIGIN"
content-length: "64"
D, [2020-01-25T23:33:21.654805 #30009] DEBUG -- response: {"count"=>1, "next"=>nil, "previous"=>nil, "results"=>[{"files"=>[]}]}
Thanks in advance!
User avatar
Posts: 658
Joined: Tue Aug 21, 2018 3:28 am
Location: Puerto Rico

Re: staging_folders API doesn't return any staged files

Post by rosarior »

Thanks for the report and for escalating it as an issue. A fix was committed along with a set of tests. The fix will be included in the next bugfix release which should be out in a few days.
Post Reply