Watch folder not working


after I updated from 4.4.8 to 4.5.2 my watch folders no longer work. When I press test the document is processed but remains in the file system.
It’s a direct install.
I get the following error message:

mayan.apps.lock_manager.backends.base <1751> [DEBUG] "acquire_lock() line 31 acquiring lock: indexing:index_instance_28, timeout: 30"
[2023-09-23 07:40:29,342: DEBUG/ForkPoolWorker-1] acquiring lock: indexing:index_instance_28, timeout: 30
mayan.apps.document_indexing.tasks <1751> [WARNING] "task_index_instance_document_add() line 50 Unable to acquire lock for document Test.pdf;  "

A fresh docker installation shows the same behavior.

I’m using elasticsearch.

Kind Regards


Thanks for the report. Looking into this.

Hi all, the same effect happens in my system. I have installed the lautest version. Document will be uploaded from the assigned Watch folder, but it won‘t be deleted und the file system after processing. Is there another way to manage the Automatik deletion?
Used Version: 4.5.3

Version 4.5.4 was published and fixes this. Please give it a try.

1 Like

Hi Roberto, thanks for your update. I am a new User of Mayan. Is there an Easy way to upgrade via portainer (stacks), without loosing current data and settings? Thanks in advance
Update: found a description in youtube, Mayan and staging folder works fine now: the deletion worked after granting the rights for the folder to “everyone read/write”. Thanks a lot. Good tool :wink:

Hello Roberto,

at first glance it works now.
Direct install and docker.
However, in my test migration, one file is still in an endless loop and is processed over and over again. Is there an easy way to stop and remove this file?
It’s best to wait until the file has been processed and simply delete it.

I run the migration completely again and test again.


maybe you should check the permission for the staging folder? In my installation (synology) I had to define the permission rw to Everyone for my folder.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.