Problem building Mayan image

Hey there!

I was trying to build the mayan image but I am getting the following error:

I installed the development dependencies and that worked fine (when retrying ever dependency is satisfied). Everything is happening in a Python venv and my Python version is 3.10.6. It should also be the only Python version on my system (python --version and python3 --version give the same result).

It seems that when I try to build it somehow does not use the venv, but it is active so I would not understand why that is.

Does anyone have any ideas regarding my issue? Thanks in advance.

Hi,

The sudo statement is switching the user and getting outside the Python virtualenv making it not possible to access the Python dependencies.

You can enable Docker for your account and this avoids having to use sudo. Example:

sudo usermod -aG docker <your username>

After logging out and in again you will be able to use the docker command as your user.

1 Like

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.