Docker Bind Address Already in Use

I’m attempting an install using docker compose on a synology nas that has portainer installed and one other container.

I am encountering the same error from the Mayan installation no matter which of these methods I use to attempt this install: Synology Container Manager, Docker CLI, Portainer

The error in question is:
“Error starting userland proxy: listen tcp4 bind: address already in use”

May I have some help resolving this conflict?


I managed to change the front-end port by changing the .env file (setting is already there)


Put whatever not-used port you want

I hope this resolves your problem


Thank you very much for your help here, and elsewhere. I have changed the setting to MAYAN_FRONTEND_HTTP_PORT=8020, and ran the docker-compose command, however I am not able to access Mayan at my ipaddress:8020

I think you need to check the firewall if any (as per your installation environment).

I used nginx to reverse proxy to ssl port and added my custom certificate… everything worked as it should be

first of all check if the system is listening on your designated port … if so then your problem is exposing it outside

Thank you again for the help, I’m actually experiencing a constant error with the container it’s infinitely stopping and starting. I have the logs here:

did you use docker compose logs for this log?
my recommendation especially if you changed something else in the docker files to fully remove the docker containers and their volumes, download docker files again and just make the port change

log is mentioning database authentication problems among other things

those logs are from my synology container manager

I’m not familiar with the synology containers, sorry for not being able to help more