Search found 685 matches

by rosarior
Tue Nov 09, 2021 9:51 am
Forum: Issues or Errors
Topic: Updating via docker compose -> 4.1.2
Replies: 1
Views: 84

Re: Updating via docker compose -> 4.1.2

Hi,

Can you post the result of the command:

Code: Select all

docker volume ls 
and

Code: Select all

docker-compose config
Exclude any result not related to Mayan or that is confidential (password, hostnames, etc).
by rosarior
Mon Oct 18, 2021 8:58 pm
Forum: Issues or Errors
Topic: [Solved] RuntimeError: Error initializing the locking backend 3.5.10 > 4.1
Replies: 10
Views: 253

Re: RuntimeError: Error initializing the locking backend 3.5.10 > 4.1

According to Redis documentation, https://redis.io/commands/select: DB index is out of range Means that the database number you are attempting to use is out of the range of the number of databases you have told Redis to provision. Double check that Mayan's LOCK_MANAGER_BACKEND_ARGUMENTS (which in th...
by rosarior
Mon Oct 18, 2021 3:52 am
Forum: Issues or Errors
Topic: [Solved] RuntimeError: Error initializing the locking backend 3.5.10 > 4.1
Replies: 10
Views: 253

Re: RuntimeError: Error initializing the locking backend 3.5.10 > 4.1

Restart Redis for the configuration change that increases the number of databases to 3 to take effect.

Code: Select all

sudo service redis-server restart
Seems that step is missing from the documentation. We'll make the update.

Thanks for the report.
by rosarior
Tue Oct 12, 2021 6:33 pm
Forum: Issues or Errors
Topic: Mayan refused to connect when upgrading 4.0.15 to 4.1
Replies: 1
Views: 134

Re: Mayan refused to connect when upgrading 4.0.15 to 4.1

In a previews post you mentioned using Mayan on port 81 due a conflict with another program. Mayan appears to be running on port 80 in you installation now. Check the logs using docker-compose logs -f this will tell if Mayan started up correctly or if there was an error booting up (wrong database/br...
by rosarior
Mon Oct 11, 2021 1:01 am
Forum: Releases
Topic: Version 4.1
Replies: 0
Views: 203

Version 4.1

Released: October 10, 2021 Status: Stable Changes General The code used to detect open file and descriptor leak detection was improved and made more strict. New descriptor leaks were fixed. File descriptors created after inspecting a Django file field (even if the file is not opened) are now explici...
by rosarior
Fri Oct 08, 2021 8:21 am
Forum: Issues or Errors
Topic: [4.1 rc2] Problem with supervisor configuration
Replies: 2
Views: 146

Re: [4.1 rc2] Problem with supervisor configuration

Version 4.2.2 is not available on Ubuntu, even in the upcoming Impish release.

It is available on Debian since bullseye and the .deb package works with Ubuntu 21.04.

https://packages.debian.org/bullseye/supervisor
2021-10-08_02-51.png
2021-10-08_02-51.png (41.86 KiB) Viewed 129 times
2021-10-08_03-18.png
2021-10-08_03-18.png (60.2 KiB) Viewed 129 times
by rosarior
Fri Oct 08, 2021 6:41 am
Forum: Issues or Errors
Topic: [4.1 rc2] Problem with supervisor configuration
Replies: 2
Views: 146

Re: [4.1 rc2] Problem with supervisor configuration

Hello, thanks for the report. Seems to be a problem with Supervisord that was fixed in version 4.2.2: http://supervisord.org/changes.html Fixed a bug where environment variables defined in environment= in the [supervisord] section or a [program:x] section could not be used in %(ENV_x)s expansions. P...
by rosarior
Tue Oct 05, 2021 3:19 am
Forum: Issues or Errors
Topic: [4.1b1] Settings > Roles: Missing action button
Replies: 2
Views: 241

Re: [4.1b1] Settings > Roles: Missing action button

The activation of the links was fixed with this commit: https://gitlab.com/mayan-edms/mayan-edm ... ede7454974

Thanks for the reports!
by rosarior
Wed Sep 29, 2021 8:25 am
Forum: Releases
Topic: Version 4.0.16
Replies: 0
Views: 210

Version 4.0.16

Released: September 29, 2021 Status: Stable Changes Appearance An issue that caused menus to reset and collapse at random was fixed. Documents On overload systems, document page image generation will reach the timeout value as display the placeholder icon for invalid images. The setting CONVERTER_IM...